WordPress Slow Performance and Other Issues
Incident Report for Engineering
Resolved
The issues have now been resolved and we believe the cause of the issue to be a problem with our third party server provider.
Posted Jul 22, 2022 - 15:00 BST
Update
Performance should have returned to normal now, however we are still investigating the cause of the issue.
Posted Jul 22, 2022 - 14:02 BST
Investigating
We are aware of an issue affecting WordPress right now causing very slow load times on pages. We are also aware of another issue relating to no posts showing on the Energy Voice admin.

We are investigating this now and will provide further updates here when possible.
Posted Jul 22, 2022 - 13:20 BST
This incident affected: WordPress Infrastructure (Admin Server).